题目要求
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
解题思路
本题主要使用了STL中的栈(stack)来模拟一个栈进行操作。
使用cur记录当前应该入栈的元素,依次读取pop sequence中的元素,对于每个读取到的元素,主要遵循以下几个原则:
- 如果要输出的元素正好是当前栈顶的元素,则栈顶出栈
- 如果要输出的元素大于等于cur,则将[cur, 要输出元素]这一区间内的元素全部入栈,然后出栈一次。出栈前判断栈是否溢出,如果溢出,则直接输出NO
- 如果要输出的元素小于cur,并且栈顶不是该元素(出栈得到的不是目的元素),则直接输出NO
一个pop sequence里的元素全部读取处理完毕,并且没有出现错误,则输出YES。
代码
#include <cstdio>
#include <cstdlib>
#include <stack>
using namespace std;
int main()
{
int num;
int m, n, k;
scanf("%d%d%d", &m, &n, &k);
bool ok = true;
for (int i = 0; i < k; i++)
{
stack<int> s;
int cur = 1;
ok = true;
for (int j = 0; j < n; j++)
{
scanf("%d", &num);
if (!ok)
{
continue;
}
if (!s.empty() && num == s.top())
{
s.pop();
}
else if (num < cur && num != s.top())
{
printf("NO\n");
ok = false;
}
else
{
while (cur <= num)
{
s.push(cur);
cur++;
}
if (s.size() > m)
{
printf("NO\n");
ok = false;
}
s.pop();
}
}
if (ok)
{
printf("YES\n");
}
}
system("pause");
return 0;
}