Back

PAT 1039 Course List for Student(25)

题目要求

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5

4 7

BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1

1 4

ANN0 BOB5 JAY9 LOR6

2 7

ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6

3 1

BOB5

5 9

AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1

ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5

ANN0 3 1 2 5

BOB5 5 1 2 3 4 5

JOE4 1 2

JAY9 4 1 2 4 5

FRA8 3 2 4 5

DON2 2 4 5

AMY7 1 5

KAT3 3 2 4 5

LOR6 4 1 2 4 5

NON9 0

时间要求

200ms

解题过程

一开始做的时候,我感觉这个题应该很简单,只要使用map将学生的名字和一个vector<int> 匹配起来,在读入数据的时候,向名称所对应的vector中不断push_back就可以了。最后输出的时候,先对vector排个序,然后按照题目要求输出就可以了。

在写完之后,一遍就通过了样例。然后我马上将代码提交的到了oj里,最后发现最后一组数据超时了。

思考之后,我觉得有可能是最后进行排序的时候超时了,所以又将vector改成了set,并且去掉了sort方法,因为set会默认进行升序排列。提交之后,发现还是超时。

我继续读题发现,题目中特别提到了学生姓名的规则为前三个字符为大写字母,第四位是一个数字,这应该是非常适合进行哈希的。就考虑到会不会是不断生成string,造成了效率过低。于是我将map修改为一个大小为26 * 26 * 26 * 10 + 1的数组,然后对学生的名字进行哈希,将哈希后的值作为index进行存储。

提交之后,成功过掉了,最后一个case耗时113ms。

代码如下:

/*
pass
2016年2月23日 10:52:14
注意:需要对学生名字做hash,否则最后一组数据会超时
*/
#include <cstdio>
#include <string>
#include <set>
#include <algorithm>

using namespace std;
const int MAXN = 26 * 26 * 26 * 10 + 1;
set<int> list[MAXN];
int hashName(char * buf)
{
	return (buf[0] - 'A') * 26 * 26 * 10 +
		(buf[1] - 'A') * 26 * 10 +
		(buf[2] - 'A') * 10 +
		(buf[3] - '0');
}

int main()
{
	char buf[5];
	int N, K;
	scanf("%d%d", &N, &K);
	for (int i = 0; i < K; i++)
	{
		int index, n;
		scanf("%d%d", &index, &n);
		for (int j = 0; j < n; j++)
		{
			scanf("%s", buf);
			list[hashName(buf)].insert(index);
		}
	}
	
	for (int i = 0; i < N; i++)
	{
		scanf("%s", buf);
		int hname = hashName(buf);
		int len = list[hname].size();
		printf("%s %d", buf, len);
		set<int>::iterator it = list[hname].begin();
		for (; it != list[hname].end(); it++)
		{
			printf(" %d", *it);
		}
		printf("\n");
	}
	
	return 0;
}